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What’s  New in version  3.23 June  2026 
  

ProVal version 3.2 3 introduces a checklist for data scripts, a redesigned data questions interface , and  a 

more streamlined report writer experience . Full details plus many other new features are listed below.  

 

Census Data  
 

Data Scripts Checklist .  A checklist feature has been added to Data Scripts, making it easy to maintain  

a to -do list for your annual data process . You can  document  what specifically needs to be changed  

each year , marking completed items alongside those  still outstanding.  

 

 
 

 

Bulk handling of Data Scripts summary output . You can now  save, print, and copy results for 

multiple (or all)  steps at once rather than one at a time.   

 

Data Questions  

• Redesigned Interface . The data questions interface  has a new design  to make it easier to 

organize, format, and generate your client -ready data questions spreadsheet. Th e new design lets 

you navigate settings in any order, making it easier to understand all available options .  
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• Preserved settings  for errors only in style . When replacing an existing data questions style and 

there are errors in the style that aren’t logged in the current database, ProVal now preserves the 

settings (description, instructions, fields) for those errors. This way those settings won’t be lost 

when you load the data questions style next year and some records are flagged with that error.  

• Reuse settings for errors only in database . When loading a data questions style and there are 

errors logged in the current database that aren't in the style, ProVal now asks if you want to copy 

settings (description, instructions, fields) from other errors in the style or use the default. For 

exampl e, if you renamed a custom screening test, you can simply copy settings from the old name 

to the new name without having to respecify them.  

• You can now select ".py" fields for current year screening tests. For example, if date of birth is 

missing, you can also  show the record's date of birth last year. To utilize this feature, you will need 

to run the screening test in version 3.23 or later.  

Database tags . You can now tag your Census Database s to allow for easy sorting and organization. For 

example, you can tag the final data used in your valuation each year with “Final” to make it stand out 

from the original client data when that is kept in a separate database.  
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Improved Merge Data  functionality.    

• There is a n ew option when merging  data to automatically read all fields from  the source  

database . This is particularly useful in a data script , since you no longer need to update the entry 

each year if your source  database has different field names . 
  

 
 

• In a data script, y ou can now specify that ProVal should  update  duplicate records if found in  your 

target database  rather than stopping the script and asking you how to proceed. Now, the script 

can run without interruption.   

  

 

 

• The name of the source  database  is now shown  in the  change history  of the target database . 

Previously, you could see that data was merged into the database but the name of the source 

database was not shown.  

 

Display historical database  name . When referencing historical data in Expression Sets, Frequency 

Tables, and Descriptive Statistics, ProVal now displays the name of th e historical database s.  Previously, 

you needed to click on Historical Data to see which databases were referenced.  

 

 
 

 

Database compare  tool now remembers your selections  in the same session.  Previously, if you left 

the comparison screen and came back later, you’d have to reenter your settings . 

 

Show changed records.  In Spreadsheet Edit, a new checkbox on the Review tab lets you filter the 

view to show just those records  affected by selected changes , highlighting changed cells in green.  
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Track Status  Field . A new option lets you start track ing  changes  to a  coded database field  within a 

database . When  enabled  in Data Scripts or Database Properties , the databas e’s Change History will 

display  the impact of each change by each code . For example, if the status of two records was 

updated from Active to Retiree, you would see +2 for the retiree code and -2 for the active code.  This 

is useful  for explaining  how participant counts  evolve d from the initial raw data file to the final 

valuation data.  

 

Report Writer  

 

Streamlined report publishing . We’ve streamlined the report definition in several ways.  

• Template as filter.  The report definition only ask s for items that are needed by your template 

document (e.g., don’t ask you for the fax number if it isn’t in the report, even if it was entered in 

last year’s report definition).  

• Import directly.  Valuation set results can be import ed directly from within the report definition 

without having to go back to your client and export them.   

• ProVal results have been moved from the Report Definition main screen and are now found under 

a “Review ProVal Results” button. This focuses the interface on the supplemental information you 

need to provide for your report.  
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Insert  Field  button  for template authors. There is a new Insert Field button in the Report Definition , 

making it more obvious how to  insert fields  into a template. Previously you could only insert a result 

into your report with a right -click into the cell.  

 

 
 

Microsoft Word Charts.  The report writer now directly supports Microsoft Word Charts (inserted via 

Insert > Chart) in addition to older Microsoft Graph Charts.  

  

Improved lookup  for assumptions tables . The report writer template document  can now lookup 

values in your plan’s assumption tables using the table’s dimensions (e.g. retirement rate for age 55 and 

5 years of service). Previously the only way to bring in assumption table values  was to use row and 

column indices.  

 

All Plans   

Scaling factors by calendar year. In core projections, scaling factor s can now vary by calendar year. 

For example, if you want to apply a set of scaling factors to only the first year of your projection, you 

can now do that without saving out an additional core projection run.  

 

 
 

 

Expanded retirement rates by age/service  on valuation date. For participants who have met the 

specified eligibility criteria as of the valuation date, you can now define a probability of retirement 

based on a set number of years from the valuation date. For example, if your plan assumes participants 

at normal retir ement age have a 75% probability of retiring in one year and are otherwise expected to 

retire at age 70, that can now be paramet erized directly without needing a set of retirement tables . 
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Sign as reviewer . You can now mark valuations as final by clicking Sign as Reviewer. Your username 

and the date are stamped on the valuation run . To remove the stamp, simply click Remove Reviewer.  

  

 

 

Expanded a ssumption constants .  You can now reference your assumption constants when defining 

conversion factor rates and election  and lapse  probabilities.  This is useful if you have the same optional 

forms with the same election assumption across various benefit definitions. Now you can define those 

election probabilities one time instead of entering the same number for each entry.  

 

 

 

Plan constants have been expanded  to the  deferral to earliest of age/service/points  option in 

payment forms.  

 

Autocomplete for temporary variables.  When entering an expression in ProVal, temporary variables 

that have been defined in the expression are now included in the list of valid operators and 

components that match what you’ve typed so far. Temporary variables are marked with (:=) in the list.  
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US Qualified Plans  

 

Sortable 415(b) Payment Form Adjustments . In Valuation Assumptions, you can now sort 415(b) 

payment form adjustments by right -clicking on the column  you want to sort by . This lets you organize  

the list by payment form or benefit component table to quickly review the inputs or make changes to 

like entries. Previously this could only be viewed using the default sorting based on Benefit Definition.    

 

 

New liabilit ies . Two new liabilit ies have been added in U.S. Qualified mode for valuations and core 

projections.  

• For PPA plans, the AFN Plan L iability used for the Annual Funding Notice, which uses the PBGC 

interest rate assumption and reflects total accrued liability, is now available. Previously a separate 

run was required  since the PBGC liability only captures the vested liability.   

• For CAS plans, the Present Value of Future Benefits using the CAS Actuarial Accrued Liability  

assumptions is now available.  

 

Canadian Registered Pension  Plans  
 

Law Updates . For Valuation Set s and  Forecast s, Nova Scotia and New Brunswick  applicable provincial 

law selections have been updated to allow specification of  a provision for adverse deviation , and solvency 

funding targets for the minimum required contribution ha ve been updated to 85%.  
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List of participants impacted by ITA Max limit.  In a valuation, p articipants impacted by the ITA 

Maximum are now displayed as part of the warning messages. This lets you  easily identify  records you 

may wish to inspect more closely. This warning can be turned off under the  Valuation Assumptions > 

Regulatory Data > Canadian Maximum Benefits ... button.   

 

Longer  accounting roll -forward. In Canadian and OPEB modes, with an accounting standard of ASPE 

3462 or IAS 19, you can now roll forward accounting results in a Valuation Set up to 3 years following the  

valuation date.  

 

CIA CPM -2024 mortality tables  have been added to a template client, available for download on our 

website. The mortality improvement scale MI -CAN -2024 [1.3%]  is included in the  same  template client 

and has been added as a standard entry in the Mortality Improvement Scales library  within ProVal . 

 

Zero pre -commencement mortality by coded field. The option to  assume zero pre -commencement 

mortality  now has additional flexibility so that you can specify a coded field, such as status, and apply 

zero pre -commencement mortality assumption to select codes only.  

 

Forecasting  
 

Funded -ratio dependent benefit increases , such as conditional indexation,  can now be modeled 

directly in ProVal using the alternate benchmark yield. In Stochastic Assumptions  >  Benchmark Yields, a 

new checkbox tells ProVal to ignore the projection assumptions for the applicable increases when the 

funded ratio is below a certain threshold.  For example, if no increase is granted when the plan is under 

100% funded.  

 

 

 

Prior Year Present Value of Employer Contributions (PVCONTPY)  is now available to use in a custom 

variable . This reflects the employer contributions through the end of the prior plan year, as used in the 

ultimate cost calculation and uses the discount rate defined in the Asset & Funding Policy>Forecast 

Analysis.  

 

Improved extrapolation.  In forecasts with unexpected benefit patterns, additional considerations have 

been added when determining the best methodology when extrapolating.  
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German Pension Plans  
 

ATZ Contracts . You can now  value ATZ contracts in ProVal.   

• Personal income tax estimates . You can now create after -tax Salary Definitions and reference them 

when defining your benefits. You will also be able to specify if the Social Security contributions 

should be subtracted . 

 
 

In Valuation Assumptions > Regulatory Data > Net Income, you can customize ProVal’s 

calculation, including the applicable tax year  and if Preliminary or Final published rates should be 

used . 

 
  

• ATZ Benefit Promises . Both the continuous and block models for ATZ contracts are supported, a s 

well as  both the remuneration and settlement characters under HGB. In the Benefit Promise, select 

the ATZ type and include Benefit Definitions with the ATZ contingency.   

 

 

• Monthly PFV for Pre -retirement benefits . The Life Annuity payment form in German mode now 

allows payments to commence and/or end at a date with monthly precision.    
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• New liability measure methods . ProVal can calculate the ATZ liability under German Tax 

Regulations, HGB, IFRS or U.S. GAAP. If using HGB or IFRS, top -up benefits can be valued under 

the degressive m -n-tel, FIFO or prepaid expense methods. If using the prepaid expense method, 

the unearne d (prepaid) expense is available as a separate individual results item (both short -term 

and total). In all cases, the liabilities and the expected benefit payments can be split into salary, 

top-up and settlement portions in the individual results.       

 

Gain/Loss Analysis  

Lapse Analysis.  For OPEB plans, you can now analyze the lapse assumption in your gain/loss.  

Previously any gain/loss associated with lapse was included in the unreconciled amount.  

 

Key ID listing in warning messages . The processing messages when running a gain/loss now list the  

impacted  participant  by key field (s), rather than by RecID.  

 

 

ProVal PS  

When viewing results for OPEB and Pension plans in aggregate , the OPEB APBO liability will now be 

added to the Pension PBO  liability.  Additionally, t he APBO label will be used instead of ABO if the 

ProVal PS file is OPEB only.  

 

ProVal API  

An optional parameter has been added to the  API function  RUNDATASCRIPT  that lets you run  the 

validate command for a Data Script.  

 

System  

User -friendly license error messages.  The license error messages have been updated so that they are 

easier to understand and provide helpful information on starting your license.  
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Grouping and sorting performance.  Grouping and sorting for  very large databases has been 

significantly sped up. In one case with a million records, the time to sort  decrease d from nearly two 

hours to about 30 minutes.  

 

Changes Log  

Be sure to read  the changes  log  (see the “changes log. pdf ” file in the ProVal  directory)  about  updates  

to certain  calculations  that may  change  results.  


